
• “Understand” annotation transfer by homology

EMBO Workshop, Norwich, 2015

• Know what protein family databases are and why 
they are useful

Goals
Marco Punta



• Homology

• Protein domains

• Exercise 1 and 2: homology-based function annotation 
transfer

• Team exercise: how to build a new (Pfam) protein 
family

EMBO Workshop, Norwich, 2015

Outline

• Protein families

Marco Punta

• Protein family databases



Homology

EMBO Workshop, Norwich, 2015
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Definition: 
Two proteins are homologous if they share a 
common ancestor, i.e. they are evolutionary 
related

EMBO Workshop, Norwich, 2015
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Origins of homology in proteins 

EMBO Workshop, Norwich, 2015
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Origin of homology in proteins

• Speciation (orthology) 

• Gene duplication (paralogy) 

• Horizontal gene transfer (xenology) 

• Whole genome duplication (ohnology) 

• Gametology,	  Synology

EMBO Workshop, Norwich, 2015
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Origin of homology in proteins

• Speciation (orthology) 

• Gene duplication (paralogy) 

• Horizontal gene transfer (xenology) 

• Whole genome duplication (ohnology) 

• Gametology,	  Synology
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Mindell and Meyer Trends in Ecology and Evolution 2001



Protein Families
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Definition: 
We call ‘family’ a group of evolutionary related 
proteins and/or protein regions

EMBO Workshop, Norwich, 2015
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http://www.studyblue.com/notes/note/n/exam-3/deck/8955883

Globins in Human



Homology: why bother?
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Figure courtesy of Alex Mitchell (EMBL-EBI) EMBO Workshop, Norwich, 2015

Marco PuntaMind the gap!



Figure courtesy of Alex Mitchell (EMBL-EBI) EMBO Workshop, Norwich, 2015

Marco Punta

Unique UniProtKB cross-references in the PDB =   35,739
http://www.ebi.ac.uk/pdbe/docs/sifts/statistics.html

Mind the gap!



Homologous protein regions have a 
similar (core) structure!

EMBO Workshop, Norwich, 2015
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Chotia and Lesk EMBO J (1986)
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Do homologous protein regions 
perform a similar function?

Homology: why bother?

EMBO Workshop, Norwich, 2015
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Schubert et al. Nat. Struct. Biol. 5 (1998)

Protein function(s)
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Schubert et al. Nat. Struct. Biol. 5 (1998)

Protein function(s)
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• A way to capture  
biological knowledge  
in a written and  
computable form

• A set of concepts  
and their relationships  
to each other

www.ebi.ac.uk/QuickGO

Slide courtesy of Alex Mitchell (EMBL-EBI)

The Gene Ontology (GO)

EMBO Workshop, Norwich, 2015

Marco Punta



1. Molecular Function

2.	  Biological	  Process

3.	  Cellular	  Component

An	  elemental	  activity	  or	  task	  or	  job

• protein	  kinase	  activity	  

• insulin	  receptor	  activity

A	  commonly	  recognised	  series	  of	  events

• cell	  division

Where	  a	  gene	  product	  is	  located

•  mitochondrion  
•  mitochondrial matrix 
•  mitochondrial inner 

membrane

Slide courtesy of Alex Mitchell (EMBL-EBI)

GO: 3 ontologies in 1

EMBO Workshop, Norwich, 2015
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EMBO Workshop, Norwich, 2015

Marco PuntaCbiF GO annotation
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Do homologous protein regions 
perform a similar function?

EMBO Workshop, Norwich, 2015

Marco Punta

Homologous proteins may share a number of functional 
features, however: 

-‐ functional drift can lead to different functions or aspects 
of function 

-‐ while functional similarity generally correlates with 
evolutionary distance, no distance is safe for inferring 
function (very closely related proteins can have slightly 
to radically different functions)



We can integrate homology with other 
information, for example:

EMBO Workshop, Norwich, 2015

Marco Punta

-‐ Functional motifs 

-‐ Conservation of functional residues 

-‐ Genomic context (mostly in bacteria) 

If structure available: 

-‐ structural motifs 

- Electrostatic, cavities, etc.



Detecting homology

EMBO Workshop, Norwich, 2015
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ALHWRAAGAATVLLVIVLLAGSYLAVLAE

ALHWRAALAATVLLVIVLLAGSWLAVLAE ALHWKAAGAATVLLVIVLLAGSYLAVLAE

Sequences of homologous proteins are related by an 
evolutionary process, they diverged from a common 
ancestor.  
Modern day homologous proteins have evolved from 
the same sequence via a number of events (mutations, 
insertions, deletions, duplications,…)

From sequence Marco Punta



Human: 1   MGLSDGEWQLVLNVWGKVEADIPGHGQEVLIRLFKGHPETLEKFDKFKHLKSEDEMKASE 60
           MGLSDGEWQLVLNVWGKVEAD  GHGQEVLI LFK HPETL KFDKFK LKSE  MK SE
Mouse: 1   MGLSDGEWQLVLNVWGKVEADLAGHGQEVLIGLFKTHPETLDKFDKFKNLKSEEDMKGSE 60

Human: 61  DLKKHGATVLTALGGILKKKGHHEAEIKPLAQSHATKHKIPVKYLEFISECIIQVLQSKH 120
           DLKKHG TVLTALG ILKKKG H AEI PLAQSHATKHKIPVKYLEFISE II VL   H
Mouse: 61  DLKKHGCTVLTALGTILKKKGQHAAEIQPLAQSHATKHKIPVKYLEFISEIIIEVLKKRH 120

Human: 121 PGDFGADAQGAMNKALELFRKDMASNYKELGFQG 154
            GDFGADAQGAM KALELFR D A  YKELGFQG
Mouse: 121 SGDFGADAQGAMSKALELFRNDIAAKYKELGFQG 154

EMBO Workshop, Norwich, 2015

Marco Punta



Protein structural and functional constraints

EMBO Workshop, Norwich, 2015Marco Punta

Trp	  (W)



http://www.jalview.org/help/html/misc/properties.gif

Marco Punta

EMBO Workshop, Norwich, 2015

aa physico-chemical properties



If divergence not too large we can hope 
to use sequence similarity to detect 
homology (excess sequence similarity*  
-> homology)

*Pearson	  Curr	  Protoc	  Bioinformatics.	  2013	  

EMBO Workshop, Norwich, 2015 Marco Punta



BLOSUM62 matrix

EMBO Workshop, Norwich, 2015
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EMBO Workshop, Norwich, 2015
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Sequence alignment, what we need: 

•  Scoring system => empirically derived 
substitution matrices (PAMs, BLOSUMs,…) 

•  Efficient way to find highest scoring alignments 
=> dynamic programming (Needleman-Wunsch, 
Smith-Waterman,…) 

•  Way to decide whether top score is high enough 
to infer homology (significance) =>   E-value, …



2G2X
2P5D

From structure

EMBO Workshop, Norwich, 2015
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Structural similarity

2G2X
2P5D

EMBO Workshop, Norwich, 2015
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Structural similarity

2G2X
2P5D

Z-score = 12.2  
RMSD = 2.9   
Lali = 122 
%id =20 DALI: http://ekhidna.biocenter.helsinki.fi/dali_lite/start

Marco Punta



Exercise 
Homology-based function annotation transfer #1

EMBO Workshop, Norwich, 2015

Marco Punta



Love et al. JSFG 2010

Punta et al. JSFG 2010

Target selection

EMBO Workshop, Norwich, 2015

Marco PuntaNYCOMPS pipeline



H. influenzae protein [3M71]

1.20 Å

Chen et al. Nature 467 (2010)

TUM,	  January	  2013
New York Consortium on Membrane Protein Structure (NYCOMPS) EMBO Workshop, Norwich, 2015

Marco PuntaPDB id



TUM,	  January	  2013EMBO Workshop, Norwich, 2015
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E-value is the number of matches with a given score 
(or higher) that we expect to occur by chance. 

This depends on database size!

EMBO Workshop, Norwich, 2015
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For an alignment with score S and E-value=1, we 
expect to have by chance 1 match with the same or 
higher score.

EMBO Workshop, Norwich, 2015
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For an alignment with score S and E-value=1, we 
expect to have by chance 1 match with the same or 
higher score. If E-value is 0.001 then we expect by 
chance 0.001 matches with the same or higher 
score.

EMBO Workshop, Norwich, 2015

Marco Punta



TUM,	  January	  2013EMBO Workshop, Norwich, 2015
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Thomine and Barbier-Brygoo Nature 467:1058-59 (2010)
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Thomine and Barbier-Brygoo Nature 467:1058-59 (2010)
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OPEN Chimera1.

File -> Open “3M71.pdb”2.

EMBO Workshop, Norwich, 2015
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Chen et al. Nature 467 (2010) EMBO Workshop, Norwich, 2015
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Actions -> Atoms/Bonds -> wire1.

Actions -> Atoms/Bonds -> show2.

EMBO Workshop, Norwich, 2015
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out

out

out

out

Actions -> Atoms/Bonds -> wire1.

Actions -> Atoms/Bonds -> show2.

EMBO Workshop, Norwich, 2015
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TUM,	  January	  2013EMBO Workshop, Norwich, 2015
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OPEN Jalview1.

2. File -> Input Alignment -> From File “PF03595_seed.txt”

EMBO Workshop, Norwich, 2015
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Colour -> BLOSUM621.

EMBO Workshop, Norwich, 2015
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Tools-> Sequence -> Multialign Viewer1.

Choose “PF03595_seed.txt”2.

Select Aligned FASTA3.

Structure -> Render by Conservation4.

EMBO Workshop, Norwich, 2015

Marco Punta
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out

out
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out

out

out

out

Actions-> Ribbon -> hide1.
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H.	  influenzae	  protein	  structure

TUM,	  January	  2013

Functional	  hypothesis	  via	  homology	  to	  SLAC1

Identification	  potential	  functional	  residues	  using	  sequence	  	  
conservation	  across	  the	  family	  and	  structural	  knowledge

Suggested	  experiments	  to	  test	  functional	  hypothesis

Thomine and Barbier-Brygoo Nature 467:1058-59 (2010)



Anion channels

exfoliative toxins

malate uptake transporter 
sulphite efflux pump

Chen et al. Nature 467 (2010) EMBO Workshop, Norwich, 2015

Marco Punta



Exercise 
Homology-based function annotation transfer #2

EMBO Workshop, Norwich, 2015
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>	  more	  Exercise_2/blast-‐2-‐seqs.link

EMBO Workshop, Norwich, 2015
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>cGMP-gated cation channel alpha-1
MKLSMKNNIINTQQSFVTMPNVIVPDIEKEIRRMENGACSSFSEDDDSASTSEESENENP
HARGSFSYKSLRKGGPSQREQYLPGAIALFNVNNSSNKDQEPEEKKKKKKEKKSKSDDKN
ENKNDPEKKKKKKDKEKKKKEEKSKDKKEEEKKEVVVIDPSGNTYYNWLFCITLPVMYNW
TMVIARACFDELQSDYLEYWLILDYVSDIVYLIDMFVRTRTGYLEQGLLVKEELKLINKY
KSNLQFKLDVLSLIPTDLLYFKLGWNYPEIRLNRLLRFSRMFEFFQRTETRTNYPNIFRI
SNLVMYIVIIIHWNACVFYSISKAIGFGNDTWVYPDINDPEFGRLARKYVYSLYWSTLTL
TTIGETPPPVRDSEYVFVVVDFLIGVLIFATIVGNIGSMISNMNAARAEFQARIDAIKQY
MHFRNVSKDMEKRVIKWFDYLWTNKKTVDEKEVLKYLPDKLRAEIAINVHLDTLKKVRIF
ADCEAGLLVELVLKLQPQVYSPGDYICKKGDIGREMYIIKEGKLAVVADDGVTQFVVLSD
GSYFGEISILNIKGSKAGNRRTANIKSIGYSDLFCLSKDDLMEALTEYPDAKTMLEEKGK
QILMKDGLLDLNIANAGSDPKDLEEKVTRMEGSVDLLQTRFARILAEYESMQQKLKQRLT
KVEKFLKPLIDTEFSSIEGPGAESGPIDST

EMBO Workshop, Norwich, 2015

Marco Punta



>mistery protein
MGNGSVKPKHSKHPDGHSGNLTTDALRNKVTELERELRRKDAEIQEREYHLKELREQLSK
QTVAIAELTEELQNKCIQLNKLQDVVHMQGGSPLQASPDKVPLEVHRKTSGLVSLHSRRG
AKAGVSAEPTTRTYDLNKPPEFSFEKARVRKDSSEKKLITDALNKNQFLKRLDPQQIKDM
VECMYGRNYQQGSYIIKQGEPGNHIFVLAEGRLEVFQGEKLLSSIPMWTTFGELAILYNC
TRTASVKAITNVKTWALDREVFQNIMRRTAQARDEQYRNFLRSVSLLKNLPEDKLTKIID
CLEVEYYDKGDYIIREGEEGSTFFILAKGKVKVTQSTEGHDQPQLIKTLQKGEYFGEKAL
ISDDVRSANIIAEENDVACLVIDRETFNQTVGTFEELQKYLEGYVANLNRDDEKRHAKRS
MSNWKLSKALSLEMIQLKEKVARFSSSSPFQNLEIIATLGVGGFGRVELVKVKNENVAFA
MKCIRKKHIVDTKQQEHVYSEKRILEELCSPFIVKLYRTFKDNKYVYMLLEACLGGELWS
ILRDRGSFDEPTSKFCVACVTEAFDYLHRLGIIYRDLKPENLILDAEGYLKLVDFGFAKK
IGSGQKTWTFCGTPEYVAPEVILNKGHDFSVDFWSLGILVYELLTGNPPFSGVDQMMTYN
LILKGIEKMDFPRKITRRPEDLIRRLCRQNPTERLGNLKNGINDIKKHRWLNGFNWEGLK
ARSLPSPLQRELKGPIDHSYFDKYPPEKGMPPDELSGWDKDF

EMBO Workshop, Norwich, 2015

Marco Punta
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Mystery	  protein	  is	  a	  cGMP-‐gated	  cation	  channel?
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P29973	  (CNGA1_HUMAN)cGMP-‐gated	  cation	  channel	  alpha-‐1
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P29973	  (CNGA1_HUMAN)cGMP-‐gated	  cation	  channel	  alpha-‐1
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474 579

281 383



1 100 200 300 400 500 600 690

1 100 200 300 400 500 600 690 762

161 260

P29973	  (CNGA1_HUMAN)cGMP-‐gated	  cation	  channel	  alpha-‐1

474 579

281 383

cGMP	  binding	  domain
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161 260

P29973	  (CNGA1_HUMAN)cGMP-‐gated	  cation	  channel	  alpha-‐1

474 579

281 383

cGMP	  binding	  domain

cGMP	  binding	  domains?



Mystery	  protein	  is	  a	  cGMP-‐dependent	  protein	  kinase	  2	  
Q13237	  (KGP2_HUMAN)
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Definition (Wikipedia): 
A protein domain is a conserved part of a given 
protein sequence and structure that can evolve, 
function, and exist independently of the rest of the 
protein chain. A domain forms a compact three-
dimensional structure and often can be 
independently stable and folded. 
(Marco): in proteins individual domains can be 
combined to perform complex functions. 

EMBO Workshop, Norwich, 2015

Marco Punta
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Z-score = 4.0 
%id  = 8% 
RMSD = 2.7Å

Winged	  helix	  domain	  (WHD)

EMBO Workshop, Norwich, 2015

Marco Punta
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Restriction endonuclease
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DNA binding (targeting to a 
specific DNA sequence)

Cleavage  
domain
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DNA binding (targeting to a 
specific DNA sequence)

Cleavage  
domain

acyl-CoA 
binding domain 
controls affinity

DNA binding!



EMBO Workshop, Norwich, 2015
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Transcription factor

Restriction endonuclease

“syntactical change”



Human methionine  
aminopeptidase 2

Vogel et al. Curr. Opin. Struct. Biol. 14 (2004) 

Transcription  
factor

Restriction  
endonuclease

Semantic change
substrate	  specificity	  pocket	  DNA	  bindingDNA	  binding

EMBO Workshop, Norwich, 2015

Marco Punta



5′-‐TGGNNNNNCCA-‐3′

5′-‐GGATG-‐3′

“syntactical change”

DNA sequence  
recognised

Transcription factor

Restriction endonuclease

EMBO Workshop, Norwich, 2015

Marco Punta



3ABZ-truncated

B

“Nested” domains

N’ C’

A A

EMBO Workshop, Norwich, 2015
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Homologous proteins may share a number of functional 
features, however: 

-‐ functional drift can lead to radically different functions 

-‐ while functional similarity correlate with function, no 
similarity threshold is safe for transfer 

-‐ if more than one functional domain is present annotation 
transfer can be attempted only between domains that 
are homologous and NOT for the full-length protein 
function

Function annotation transfer by homology



•Members will be structurally similar 

•Members may share aspects of function 

•Also, the whole set of members may reveal elements of 
protein and organism evolution 

Protein families

EMBO Workshop, Norwich, 2015

Marco Punta



The sequence space

EMBO Workshop, Norwich, 2015



The sequence space and annotated proteins

EMBO Workshop, Norwich, 2015



The sequence space and annotated proteins

EMBO Workshop, Norwich, 2015
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Annotation transfer by homology
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Annotation transfer by homology

EMBO Workshop, Norwich, 2015



Protein family databases



Build MSA of 
representative members

Build profile model

Use model to identify more members

Annotate

Building families 
(Pfam)

Identify target

QCs

EMBO Workshop, Norwich, 2015

Marco Punta



Human: 1   MGLSDGEWQLVLNVWGKVEADIPGHGQEVLIRLFKGHPETLEKFDKFKHLKSEDEMKASE 60
    

Human: 61  DLKKHGATVLTALGGILKKKGHHEAEIKPLAQSHATKHKIPVKYLEFISECIIQVLQSKH 120
          

Human: 121 PGDFGADAQGAMNKALELFRKDMASNYKELGFQG 154
          



Family power

EMBO Workshop, Norwich, 2015
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Family power
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Human: 1   MGLSDGEWQLVLNVWGKVEADIPGHGQEVLIRLFKGHPETLEKFDKFKHLKSEDEMKASE 60
           MGLSDGEWQLVLNVWGKVEAD  GHGQEVLI LFK HPETL KFDKFK LKSE  MK SE
Mouse: 1   MGLSDGEWQLVLNVWGKVEADLAGHGQEVLIGLFKTHPETLDKFDKFKNLKSEEDMKGSE 60

Human: 61  DLKKHGATVLTALGGILKKKGHHEAEIKPLAQSHATKHKIPVKYLEFISECIIQVLQSKH 120
           DLKKHG TVLTALG ILKKKG H AEI PLAQSHATKHKIPVKYLEFISE II VL   H
Mouse: 61  DLKKHGCTVLTALGTILKKKGQHAAEIQPLAQSHATKHKIPVKYLEFISEIIIEVLKKRH 120

Human: 121 PGDFGADAQGAMNKALELFRKDMASNYKELGFQG 154
            GDFGADAQGAM KALELFR D A  YKELGFQG
Mouse: 121 SGDFGADAQGAMSKALELFRNDIAAKYKELGFQG 154

Family power

EMBO Workshop, Norwich, 2015

Marco Punta



Family power

EMBO Workshop, Norwich, 2015
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seq> AWRTWEAPIFLKRYSTLPGGRAS…



Family power

EMBO Workshop, Norwich, 2015
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seq> AWRTWEAPIFLKRYSTLPGGRAS…



Family power

EMBO Workshop, Norwich, 2015

Marco Punta

seq> AWRTWEAPIFLKRYSTLPGGRAS…

score(ab,i)



Sequence-profile alignments

• Position specific substitution matrices 

• profile-hidden Markov models



Build MSA of 
representative members

Build profile model

Use model to identify more members

Annotate

Building families 
(Pfam)

Identify target

QCs

EMBO Workshop, Norwich, 2015

Marco Punta



~1000 domains~4400 families

Functions,	  organisms,	  structures

Signalling, extracellular and 
chromatin-associated proteins 

Prokaryotes

EMBO Workshop, Norwich, 2015

Marco Punta

Structural domains from SCOP

Gene3D
Structural domains from CATH



~14000 families

No	  limits,	  domains

EMBO Workshop, Norwich, 2015

Marco Punta



>7000 families, >50000 subfamilies 

No	  limits,	  full-‐length	  proteins

~2000 families

EMBO Workshop, Norwich, 2015

Marco Punta



Integration

CDD

Uses RPS-BLAST

EMBO Workshop, Norwich, 2015

Marco Punta



Integration

EMBO Workshop, Norwich, 2015
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Structural 
domains

Functional annotation of families/
domains

Protein 
features  
(sites)

Hidden Markov Models Finger 
prints

HAMAP

Member databases

Slide courtesy of Alex Mitchell (EMBL-EBI) EMBO Workshop, Norwich, 2015

Marco Punta













Orthologous	  families,	  trees

Pros: 
Better prediction of protein function (in principle, ortholog conjecture) 
Gene history 
Species trees 

Caveats:  
Lateral gene transfer difficult to model/recognise -> bacteria difficult 
Gene loss difficult to account for, may lead to wrong ortho-para assignment 
Large families difficult to model



Team Exercise 
Building a new Pfam family

EMBO Workshop, Norwich, 2015

Marco Punta







145

























File -> Input alignment -> From file1.



Edit -> Remove redundancy1.

Select 90% and Remove2.



Edit -> Remove redundancy1.

2.

Edit -> Remove empty columns3.

Select 90% and Remove



Edit -> Remove redundancy1.

2.

Edit -> Remove empty columns3.

Colour -> Clustalx4.

Select 90% and Remove









Edit -> Delete1.

Colour -> BLOSUM62 Score2. / Colour -> Percentage Identity





Edit -> Remove left1.





Edit -> Remove right1.





File -> Save as1.
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