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•  “Understand” annotation transfer by homology 

•  Know what protein family databases are and why 
they are useful 

Goals 
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•  Homology (definition, implications, how to detect) 

•  Protein domains 

•  Exercise 1 and 2: homology-based function  
annotation transfer 

•  Exercise 3: how to build a new (Pfam) protein family 

Outline 

•  Protein families 
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Homology 
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Definition: 
Two proteins are homologous if they share a 
common ancestor, i.e. they are evolutionary 
related 
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Origins of homology in proteins  
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Origin of homology in proteins 

•  Speciation (orthology) 

•  Gene duplication (paralogy) 

•  Horizontal gene transfer (xenology) 

•  Whole genome duplication 
(ohnology) 

•  Gametology,	Synology 
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Mindell and Meyer Trends in Ecology and Evolution 2001 



Protein Families 
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Definition: 
We call ‘family’ a group of evolutionary related 
proteins and/or protein regions 

Marco Punta 
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http://www.studyblue.com/notes/note/n/exam-3/deck/8955883 

Globins in Human 



Homology: why bother? 
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Figure courtesy of Alex Mitchell (EMBL-EBI) 
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Figure courtesy of Alex Mitchell (EMBL-EBI) 
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Unique UniProtKB cross-references in the PDB =   38,226 
http://www.ebi.ac.uk/pdbe/docs/sifts/statistics.html

Mind the gap! 
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Figure courtesy of Alex Mitchell (EMBL-EBI) 
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Homology: why bother? 

Marco Punta 
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Homologous	proteins	come	from		
a	common	ancestor,	that	is,	a	single	

ancestral	protein	with	given	sequence,	
structure	and	func9ons	

Marco Punta 
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Homology							similar	sequence?	
	
Homology							similar	structure?	
	
Homology							similar	func9on?	
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Homologous protein regions have a 
similar (core) structure! 

Marco Punta 

Chothia and Lesk EMBO J (1986) 
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Homology	 Structural	similarity	
(same	fold)	

Marco	Punta	 EMBO Workshop, Budapest, 2016 



Different	fold	 Not	Homologous	

Marco	Punta	 EMBO Workshop, Budapest, 2016 



Detecting homology	

EMBO Workshop, Budapest, 2016 
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ALHWRAAGAATVLLVIVLLAGSYLAVLAE	

ALHWRAALAATVLLVIVLLAGSWLAVLAE	 ALHWKAAGAATVLLVIVLLAGSYLAVLAE	

Sequences of homologous proteins are related by an 
evolutionary process, they diverged from a common 
ancestor.  
Modern day homologous proteins have evolved from 
the same ancestral sequence via a number of events 
(mutations, insertions, deletions, truncations,…) 

From sequence	

EMBO Workshop, Budapest, 2016 

Marco Punta 



Human: 1   MGLSDGEWQLVLNVWGKVEADIPGHGQEVLIRLFKGHPETLEKFDKFKHLKSEDEMKASE 60
           MGLSDGEWQLVLNVWGKVEAD  GHGQEVLI LFK HPETL KFDKFK LKSE  MK SE
Mouse: 1   MGLSDGEWQLVLNVWGKVEADLAGHGQEVLIGLFKTHPETLDKFDKFKNLKSEEDMKGSE 60

Human: 61  DLKKHGATVLTALGGILKKKGHHEAEIKPLAQSHATKHKIPVKYLEFISECIIQVLQSKH 120
           DLKKHG TVLTALG ILKKKG H AEI PLAQSHATKHKIPVKYLEFISE II VL   H
Mouse: 61  DLKKHGCTVLTALGTILKKKGQHAAEIQPLAQSHATKHKIPVKYLEFISEIIIEVLKKRH 120

Human: 121 PGDFGADAQGAMNKALELFRKDMASNYKELGFQG 154
            GDFGADAQGAM KALELFR D A  YKELGFQG
Mouse: 121 SGDFGADAQGAMSKALELFRNDIAAKYKELGFQG 154	

84%	iden99es!	

Marco	Punta	 EMBO Workshop, Budapest, 2016 
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Human: 1   MGLSDGEWQLVLNVWGKVEADIPGHGQEVLIRLFKGHPETLEKFDKFKHLKSEDEMKASE 60
           MGLSDGEWQLVLNVWGKVEAD  GHGQEVLI LFK HPETL KFDKFK LKSE  MK SE
Mouse: 1   MGLSDGEWQLVLNVWGKVEADLAGHGQEVLIGLFKTHPETLDKFDKFKNLKSEEDMKGSE 60

Human: 61  DLKKHGATVLTALGGILKKKGHHEAEIKPLAQSHATKHKIPVKYLEFISECIIQVLQSKH 120
           DLKKHG TVLTALG ILKKKG H AEI PLAQSHATKHKIPVKYLEFISE II VL   H
Mouse: 61  DLKKHGCTVLTALGTILKKKGQHAAEIQPLAQSHATKHKIPVKYLEFISEIIIEVLKKRH 120

Human: 121 PGDFGADAQGAMNKALELFRKDMASNYKELGFQG 154
            GDFGADAQGAM KALELFR D A  YKELGFQG
Mouse: 121 SGDFGADAQGAMSKALELFRNDIAAKYKELGFQG 154	

How	can	we	explain	“excess	sequence	
similarity”*	with	respect	to	what	we	expect	at	
random?	

84%	iden99es!	

*Pearson	Curr	Protoc	Bioinforma9cs	2013	
EMBO Workshop, Budapest, 2016 
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Seq1	

Seq2	

Homology:	divergent	evolu9on	

Common	ancestor	

Stevens J Mol Recogn (2007) !
Elias and Tawfik J Biol Chem (2012)!

EMBO Workshop, Budapest, 2016 
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Seq1	

Seq2	

Same	func9on	

Analogy	I:	convergent	evolu9on	

Analogy	II:	concurrence	

Seq1	

Seq2	

Same	structure	

Stevens J Mol Recogn (2007) !
Elias and Tawfik J Biol Chem (2012)! EMBO Workshop, Budapest, 2016 
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"Triad Convergence" by Thomas Shafee - Own work. Licensed under CC BY-SA 3.0 via Wikimedia Commons - 
https://commons.wikimedia.org/wiki/File:Triad_Convergence.png#/media/File:Triad_Convergence.png!

See	the	Book:	Sequence	-	Evolu9on	-	Func9on:	Computa9onal	Approaches	in	Compara9ve	Genomics.	Koonin	and	Galperin	(2003)	

Marco Punta 



Stebbins	and	Galán		Nature	412	(2001)	

Salmonella	virulence	factor	SptP	

Tyrosine	phosphatase	 Rho	GTPase	ac9va9ng	domain	

EMBO Workshop, Budapest, 2016 

Ac9va9on	of	GTPases	by	
Salmonella	GAP	leads	to	
profuse	rearrangements	
of	the	ac9n	
cytoskeleton	and	
subsequent	bacterial	
internaliza9on	into	
intes9nal	epithelial	
cells.		



Seq1	

Seq2	

Same	func9on	

Analogy	I:	convergent	evolu9on	

Analogy	II:	concurrence	

Seq1	

Seq2	

Same	structure	

Stevens J Mol Recogn (2007) !
Elias and Tawfik J Biol Chem (2012)! EMBO Workshop, Budapest, 2016 

Marco Punta 



Figure	5.	Comparison	of	YxeF	NMR	structure	(PDB	ID	2JOZ,	coded	in	blue)	and	Blc	X-ray	crystal	structure	(PDB	ID	
3MBT,	orange).	

Wu	Punta	et	al.	PLoS	ONE	(2012)	

17%	seq.	id.,	Z-score	of	structural	superposi9on	(DALI)	6.9	

1.8	Å	



Human: 1   MGLSDGEWQLVLNVWGKVEADIPGHGQEVLIRLFKGHPETLEKFDKFKHLKSEDEMKASE 60
           MGLSDGEWQLVLNVWGKVEAD  GHGQEVLI LFK HPETL KFDKFK LKSE  MK SE
Mouse: 1   MGLSDGEWQLVLNVWGKVEADLAGHGQEVLIGLFKTHPETLDKFDKFKNLKSEEDMKGSE 60

Human: 61  DLKKHGATVLTALGGILKKKGHHEAEIKPLAQSHATKHKIPVKYLEFISECIIQVLQSKH 120
           DLKKHG TVLTALG ILKKKG H AEI PLAQSHATKHKIPVKYLEFISE II VL   H
Mouse: 61  DLKKHGCTVLTALGTILKKKGQHAAEIQPLAQSHATKHKIPVKYLEFISEIIIEVLKKRH 120

Human: 121 PGDFGADAQGAMNKALELFRKDMASNYKELGFQG 154
            GDFGADAQGAM KALELFR D A  YKELGFQG
Mouse: 121 SGDFGADAQGAMSKALELFRNDIAAKYKELGFQG 154	

84%	iden99es!	

How	can	we	explain	“excess	sequence	
similarity”*	with	respect	to	what	we	expect	at	
random?	

*Pearson	Curr	Protoc	Bioinforma9cs	2013	
EMBO Workshop, Budapest, 2016 
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“[…]we	are	jus9fied	to	conclude	that	whenever	sta9s9cally	significant	
sequence	or	structural	similarity	between	proteins	or	protein	domains	is	
observed,	this	is	an	indica9on	of	their	divergent	evolu9on	from	a	common	
ancestor	or,	in	other	words,	evidence	of	homology.”	

Koonin	and	Galperin	(2003)	

Marco	Punta	 EMBO Workshop, Budapest, 2016 
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Excess	sequence	similarity	 Homology	

Marco	Punta	 EMBO Workshop, Budapest, 2016 
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Sequence alignment, what we need: 
 
•  Scoring system => empirically derived 
substitution matrices (PAMs, BLOSUMs,…) 

•  Efficient way to find highest scoring alignments 
=> dynamic programming (Needleman-Wunsch, 
Smith-Waterman,…) 

•  Way to decide whether top score is high enough 
to infer homology (significance) =>   E-value, …	

Marco	Punta	 EMBO Workshop, Budapest, 2016 

Marco Punta 
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Sequence alignment, what we need: 
 
•  Scoring system => empirically derived 
substitution matrices (PAMs, BLOSUMs,…) 

•  Efficient way to find highest scoring alignments 
=> dynamic programming (Needleman-Wunsch, 
Smith-Waterman,…) 

•  Way to decide whether top score is high enough 
to infer homology (significance) =>   E-value, …	
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Image	credits:	hAp://www.ncbi.nlm.nih.gov/books/NBK22456/figure/A937/?report=objectonly	



MYG_HUMAN     1 MGLSDGEWQLVLNVWGKVEADIPGHGQEVLIRLFKGHPETLEKFDKFKHLKSEDEMKASE 60                                                           
                M LS      V   WGKV A     G E L R F   P T   F  F      D    S
E9M4D4_HUMAN  1 MVLSPADKTNVKAAWGKVGAHAGEYGAEALERMFLSFPTTKTYFPHF------DLSHGSA 54                                                               

MYG_HUMAN    61 DLKKHGATVLTALGGILKKKGHHEAEIKPLAQSHATKHKI-PVKY  104                                              
                  K H   V  AL                L   HA K    PV  
E9M4D4_HUMAN 55 QVKGHSKKVADALTNAVAHVDDMPNALSALSDLHAHKLRVDPVNF   99                                              

Marco	Punta	 EMBO Workshop, Budapest, 2016 
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BLOSUM62 matrix	
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hAp://www.jalview.org/help/html/misc/proper9es.gif	

aa	physico-chemical	proper9es	
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Protein structural and functional constraints	

Trp	(W)	

Marco	Punta	 EMBO Workshop, Budapest, 2016 
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2EVE	
1J2B	

DALI: http://ekhidna.biocenter.helsinki.fi/dali_lite/start	Z-score = 2.0  
RMSD = 3.2   
Lali = 54 
%id = 6	 Bertona9,	Punta	et	al.	Proteins	2009	

From structure	
Marco Punta 

CE,	VAST,	FATCAT,	PDBeFold,	...	



Homology	 Structural	similarity	
(same	fold)	

Marco	Punta	 EMBO Workshop, Budapest, 2016 
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Cheng	et	al.	Nucleic	Acids	Res.	2008	

hAp://prodata.swmed.edu/malisam/	



Rackham	et	al.	J	Mol	Biol.	2010		



Apostolovic	et	al.	Chem.	Soc.	Rev.,	2010			
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Rackham	et	al.	J	Mol	Biol.	2010		

Coiled-coil	evolu9on	



Homology	 Structural	similarity	

Marco	Punta	 EMBO Workshop, Budapest, 2016 
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Image	credits:	hAp://www.ncbi.nlm.nih.gov/books/NBK22456/figure/A937/?report=objectonly	



Excess	sequence	similarity	 Homology	

Marco	Punta	

?	

EMBO Workshop, Budapest, 2016 
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Unrelated	proteins	

Burkhard Rost Protein Eng. 1999;12:85-94 
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Unrelated	proteins	

Related	proteins	

Burkhard Rost Protein Eng. 1999;12:85-94 
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Excess	sequence	similarity	 Homology	
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Homology							similar	sequence?	
	
Homology							similar	structure?	
	
Homology							similar	func9on?	
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Homology	 Similar	func9on	?	
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Schubert et al. Nat. Struct. Biol. 5 (1998)	

Protein function(s)	 Marco Punta 
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Schubert et al. Nat. Struct. Biol. 5 (1998)	
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Protein function(s)	

Catalytic activity 

methyltransferase 

precorrin-4 
methyltransferase activity 

CbiF

Marco	Punta	

Marco Punta 
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Schubert et al. Nat. Struct. Biol. 5 (1998)	

Protein function(s)	 Marco Punta 
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Moore et al. PNAS 110 (2013)	

Cobalamin biosynthetic pathways	 Marco Punta 
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Moore et al. PNAS 110 (2013)	

Cobalamin biosynthetic pathways	 Marco Punta 
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Protein function(s)	

Catalytic activity 

methyltransferase 

CbiF

Cobalamin 
biosynthetic process 

precorrin-4 
methyltransferase activity 

Marco	Punta	

Marco Punta 
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Moore et al. PNAS 110 (2013)	

Cobalamin biosynthetic pathways	 Marco Punta 

EMBO Workshop, Budapest, 2016 



Protein function(s)	

Catalytic activity 

methyltransferase 

CbiF

CbiA

Catalytic activity 

hydrolase activity 

cobyrinic acid a,c-diamide 
synthase activity 

Cobalamin 
biosynthetic process 

precorrin-4 
methyltransferase activity 



Protein function(s)	

Catalytic activity 

methyltransferase 

CbiF

CbiA

Catalytic activity 

hydrolase activity 

cobyrinic acid a,c-diamide 
synthase activity 

Cobalamin 
biosynthetic process 

Molecular function Biological process 

Molecular function 

precorrin-4 
methyltransferase activity 



•  A way to capture 	
biological knowledge 	
in a written and 	
computable form	

•  A set of concepts 	
and their relationships 	
to each other	

www.ebi.ac.uk/QuickGO	

Slide courtesy of Alex Mitchell (EMBL-EBI)	

The Gene Ontology (GO)	 Marco Punta 

EMBO Workshop, Budapest, 2016 



1.	Molecular	Func9on	

2.	Biological	Process	

3.	Cellular	Component	

An	elemental	ac9vity	or	task	or	job	

•  protein	kinase	ac9vity	
•  insulin	receptor	ac9vity	

A	commonly	recognised	series	of	events	

•  cell	division	

Where	a	gene	product	is	located	

•  	mitochondrion		
•  	mitochondrial	matrix	
•  	mitochondrial	inner	membrane	

Slide courtesy of Alex Mitchell (EMBL-EBI)	

GO: 3 ontologies in 1	
Marco Punta	Marco Punta 

EMBO Workshop, Budapest, 2016 



Bacillus megaterium CbiF GO annotation	
Marco Punta 

EMBO Workshop, Budapest, 2016 



hAps://en.wikipedia.org/wiki/Enzyme_Commission_number	



Image	Credits: http://legacy.earlham.edu/~merkeka/EMBL_EBI-top.gif	





SAME	

SAME	

SAME	

SAME	



Punta and Ofran PLOS CB (2008)	

Marco Punta 
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Moonlighting proteins	

Jeffery Trends Bioch. Sc. (1999)	

Marco Punta 

EMBO Workshop, Budapest, 2016 



Do homologous protein regions 
perform a similar function? 

Marco Punta 

Homologous proteins may share a number of functional 
features, however: 
 
-  functional drift can lead to different functions or aspects 

of function 
 
-  while functional similarity generally correlates with 

evolutionary distance, no distance is safe for inferring 
function (very closely related proteins can have slightly 
to radically different functions) 

EMBO Workshop, Budapest, 2016 
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Unrelated	proteins	

Burkhard Rost Protein Eng. 1999;12:85-94 



Exercise 
Homology-based function annotation transfer #1 

Marco Punta 

EMBO Workshop, Budapest, 2016 



Love et al. JSFG 2010

Punta et al. JSFG 2010

Target selection

Marco Punta NYCOMPS pipeline 

EMBO Workshop, Budapest, 2016 



H. influenzae protein [3M71] 
1.20 Å 

Chen et al. Nature 467 (2010) 

TUM,	January	2013	
New York Consortium on Membrane Protein Structure (NYCOMPS) 

Marco Punta PDB id 

EMBO Workshop, Budapest, 2016 



TUM,	January	2013	

Marco Punta 
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E-value is the number of matches with a given score 
(or higher) that we expect to occur by chance. 
 
This depends on database size! 

Marco Punta 

EMBO Workshop, Budapest, 2016 



 
 
For an alignment with score S and E-value=1, we 
expect to have by chance 1 match with the same or 
higher score. 

Marco Punta 

EMBO Workshop, Budapest, 2016 



 
 
For an alignment with score S and E-value=1, we 
expect to have by chance 1 match with the same or 
higher score. If E-value is 0.001 then we expect by 
chance 0.001 matches with the same or higher 
score. 

EMBO Workshop, Budapest, 2016 

Marco Punta 



Thomine and Barbier-Brygoo Nature 467:1058-59 (2010) 

Marco Punta 
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Thomine and Barbier-Brygoo Nature 467:1058-59 (2010) 

Marco Punta 

EMBO Workshop, Budapest, 2016 



Marco Punta 

hAp://aidanbudd.github.io/ppisnd/trainingMaterial/marcoPunta/	



OPEN Chimera 1.	

File -> Open “3M71.pdb” 2.	

Marco Punta 

EMBO Workshop, Budapest, 2016 
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Chen et al. Nature 467 (2010) 

Marco Punta 
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Chen et al. Nature 467 (2010) 
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Chen et al. Nature 467 (2010) 

Marco Punta 
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Actions -> Atoms/Bonds -> wire 1.	

Actions -> Atoms/Bonds -> show 2.	
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Actions -> Atoms/Bonds -> wire 1.	

Actions -> Atoms/Bonds -> show 2.	
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File -> Fetch by ID 1.	

1.	

2.	

3.	
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Hold	down		
‘Shix’		
key	to	select	
mul9ple	
cavi9es	
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Favorites -> Model panel 1.	



Marco Punta 

EMBO Workshop, Budapest, 2016 

Favorites -> Model panel 1.	
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Favorites -> Model panel 1.	



Marco Punta 

EMBO Workshop, Budapest, 2016 

File -> Open “3M71_del.pdb” 1.	
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File -> Open “3M71_del.pdb” 1.	



Actions -> Color -> all options 2.	
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File -> Open “3M71_del.pdb” 1.	



Click on ‘background’ and select red 3.	
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Actions -> Color -> all options 2.	

File -> Open “3M71_del.pdb” 1.	
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Select -> Chain -> A -> 3m71_del.pdb (#1)  1.	

Actions-> Surface -> show 2.	
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Select -> Chain -> A -> 3m71_del.pdb (#1)  1.	

Actions-> Surface -> show 2.	



Marco Punta 

EMBO Workshop, Budapest, 2016 

Favorites -> Side View 1.	
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Favorites -> Side View 1.	
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Favorites -> Model panel 1.	



Click on ‘background’ and select black 3.	
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Actions -> Color -> all options 2.	

File -> Open “3M71_del.pdb” 1.	
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TUM,	January	2013	
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OPEN Jalview 1.	

2.	 File -> Input Alignment -> From File “PF03595_seed.txt” 
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Colour -> BLOSUM62 1.	
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Tools-> Sequence -> Multialign Viewer 1.	

Choose “PF03595_seed_mod.txt” 2.	

Select Aligned FASTA 3.	
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Tools-> Sequence -> Multialign Viewer 1.	

Choose “PF03595_seed_mod.txt” 2.	

Select Aligned FASTA 3.	

Structure -> Render by Conservation 4.	
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Actions-> Ribbon -> hide 1.	
Marco Punta 

EMBO Workshop, Budapest, 2016 





Chen et al. Nature 467 (2010) 

Marco Punta 

EMBO Workshop, Budapest, 2016 



Chen et al. Nature 467 (2010) 

Marco Punta 

EMBO Workshop, Budapest, 2016 



Chen et al. Nature 467 (2010) 

Marco Punta 

EMBO Workshop, Budapest, 2016 



H.	influenzae	protein	structure	

TUM,	January	2013	

Func9onal	hypothesis	via	homology	to	SLAC1	

Iden9fica9on	poten9al	func9onal	residues	using	sequence		
conserva9on	across	the	family	and	structural	knowledge	

Suggested	experiments	to	test	func9onal	hypothesis	

Thomine and Barbier-Brygoo Nature 467:1058-59 (2010) 



Anion channels 

exfoliative toxins 

malate uptake transporter 
sulphite efflux pump 

Chen et al. Nature 467 (2010) 
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Exercise 
Homology-based function annotation transfer #2 
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hAp://aidanbudd.github.io/ppisnd/trainingMaterial/marcoPunta/	



>sp|P29973|CNGA1_HUMAN	cGMP-gated	ca9on	channel	alpha-1	OS=Homo	sapiens	
MKLSMKNNIINTQQSFVTMPNVIVPDIEKEIRRMENGACSSFSEDDDSASTSEESENENP
HARGSFSYKSLRKGGPSQREQYLPGAIALFNVNNSSNKDQEPEEKKKKKKEKKSKSDDKN
ENKNDPEKKKKKKDKEKKKKEEKSKDKKEEEKKEVVVIDPSGNTYYNWLFCITLPVMYNW
TMVIARACFDELQSDYLEYWLILDYVSDIVYLIDMFVRTRTGYLEQGLLVKEELKLINKY
KSNLQFKLDVLSLIPTDLLYFKLGWNYPEIRLNRLLRFSRMFEFFQRTETRTNYPNIFRI
SNLVMYIVIIIHWNACVFYSISKAIGFGNDTWVYPDINDPEFGRLARKYVYSLYWSTLTL
TTIGETPPPVRDSEYVFVVVDFLIGVLIFATIVGNIGSMISNMNAARAEFQARIDAIKQY
MHFRNVSKDMEKRVIKWFDYLWTNKKTVDEKEVLKYLPDKLRAEIAINVHLDTLKKVRIF
ADCEAGLLVELVLKLQPQVYSPGDYICKKGDIGREMYIIKEGKLAVVADDGVTQFVVLSD
GSYFGEISILNIKGSKAGNRRTANIKSIGYSDLFCLSKDDLMEALTEYPDAKTMLEEKGK
QILMKDGLLDLNIANAGSDPKDLEEKVTRMEGSVDLLQTRFARILAEYESMQQKLKQRLT
KVEKFLKPLIDTEFSSIEGPGAESGPIDST	

Marco Punta 

EMBO Workshop, Budapest, 2016 



>mistery protein
MGNGSVKPKHSKHPDGHSGNLTTDALRNKVTELERELRRKDAEIQEREYHLKELREQLSK
QTVAIAELTEELQNKCIQLNKLQDVVHMQGGSPLQASPDKVPLEVHRKTSGLVSLHSRRG
AKAGVSAEPTTRTYDLNKPPEFSFEKARVRKDSSEKKLITDALNKNQFLKRLDPQQIKDM
VECMYGRNYQQGSYIIKQGEPGNHIFVLAEGRLEVFQGEKLLSSIPMWTTFGELAILYNC
TRTASVKAITNVKTWALDREVFQNIMRRTAQARDEQYRNFLRSVSLLKNLPEDKLTKIID
CLEVEYYDKGDYIIREGEEGSTFFILAKGKVKVTQSTEGHDQPQLIKTLQKGEYFGEKAL
ISDDVRSANIIAEENDVACLVIDRETFNQTVGTFEELQKYLEGYVANLNRDDEKRHAKRS
MSNWKLSKALSLEMIQLKEKVARFSSSSPFQNLEIIATLGVGGFGRVELVKVKNENVAFA
MKCIRKKHIVDTKQQEHVYSEKRILEELCSPFIVKLYRTFKDNKYVYMLLEACLGGELWS
ILRDRGSFDEPTSKFCVACVTEAFDYLHRLGIIYRDLKPENLILDAEGYLKLVDFGFAKK
IGSGQKTWTFCGTPEYVAPEVILNKGHDFSVDFWSLGILVYELLTGNPPFSGVDQMMTYN
LILKGIEKMDFPRKITRRPEDLIRRLCRQNPTERLGNLKNGINDIKKHRWLNGFNWEGLK
ARSLPSPLQRELKGPIDHSYFDKYPPEKGMPPDELSGWDKDF

Marco Punta 

EMBO Workshop, Budapest, 2016 



hAp://blast.ncbi.nlm.nih.gov/Blast.cgi?PAGE=Proteins	
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Mystery	protein	is	a	cGMP-gated	ca9on	channel?	

Marco Punta 

EMBO Workshop, Budapest, 2016 
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Definition (Wikipedia): 
 
A	protein	domain	is	a	conserved	part	of	a	given	protein	sequence	and	(ter9ary)	
structure	that	can	evolve,	func9on,	and	exist	independently	of	the	rest	of	the	protein	
chain.	Each	domain	forms	a	compact	three-dimensional	structure	and	oxen	can	be	
independently	stable	and	folded.	
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EMBO Workshop, Budapest, 2016 
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Z-score = 4.0 
%id = 8% 
RMSD  = 2.7Å	

Winged	helix	domain	(WHD)	
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EMBO Workshop, Budapest, 2016 



N’	

Colour	Scheme:	

C’	

1HW2	

1FOK	
Marco Punta 

EMBO Workshop, Budapest, 2016 



1HW2	

1FOK	

Restriction endonuclease	
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DNA binding (targeting to a 
specific DNA sequence) 

Cleavage  
domain	

Marco Punta 

EMBO Workshop, Budapest, 2016 



1HW2	

1FOK	

DNA binding (targeting to a 
specific DNA sequence) 

Cleavage  
domain	

DNA binding? 
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1HW2	

1FOK	

DNA binding (targeting to a 
specific DNA sequence) 

Cleavage  
domain	

acyl-CoA 
binding domain 
controls affinity	

DNA binding! 
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1HW2	

1FOK	

Transcription factor	

Restriction endonuclease	

“syntactical change”	
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Human methionine  
aminopeptidase 2	

Vogel et al. Curr. Opin. Struct. Biol. 14 (2004) 	

Transcription  
factor	

Restriction  
endonuclease	

Semantic change	
substrate	specificity	pocket		DNA	binding	DNA	binding	

Marco Punta 
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5ʹ-TGGNNNNNCCA-3ʹ	

5ʹ-GGATG-3ʹ	

“syntactical change”	

DNA sequence  
recognised	

Transcription factor	

Restriction endonuclease	
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3ABZ-truncated	

B	

“Nested” domains	

N’	 C’	

A	 A	
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domain	
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domain	

cGMP	binding	domains?	

Ion	transport	
Leu-zipper		
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Protein	kinase		
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Mystery	protein	is	a	cGMP-dependent	protein	kinase	2	
Q13237	(KGP2_HUMAN)	

Marco Punta 
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Definition (Wikipedia): 
 
A	protein	domain	is	a	conserved	part	of	a	given	protein	sequence	and	(ter9ary)	
structure	that	can	evolve,	func9on,	and	exist	independently	of	the	rest	of	the	protein	
chain.	Each	domain	forms	a	compact	three-dimensional	structure	and	oxen	can	be	
independently	stable	and	folded.	Many	proteins	consist	of	several	structural	
domains.	One	domain	may	appear	in	a	variety	of	different	proteins.	Molecular	
evolu9on	uses	domains	as	building	blocks	and	these	may	be	recombined	in	different	
arrangements	to	create	proteins	with	different	func9ons.	

Marco Punta 
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Homologous proteins can share a number of functional 
features, however: 

 
- functional drift can lead to radically different functions 

- while functional similarity correlates with function, no 
similarity threshold is safe for transfer 

- Proteins may have multiple functions 

- if more than one functional domain is present annotation 
transfer can be attempted only between domains that 
are homologous and NOT for the full-length protein 
function (but still not ‘safe’)	

Function annotation transfer by homology 

Marco	Punta	 EMBO Workshop, Budapest, 2016 



Water-soluble, globe-like shape. 

Globular proteins? 

Non globular proteins? 

Membrane proteins, fibrous proteins, disordered proteins 
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Homology							similar	sequence?	
	
Homology							similar	structure?	
	
Homology							similar	func9on?	
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hAps://en.wikipedia.org/wiki/Interolog#/media/File:Hypothe9calInterologExample.png	
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Interologs	



Wiles	et	al.	BMC	Syst	Biol.	2010	hAp://interologfinder.org/simpleIfWS?opera9on=doStart	



hAp://gemdock.life.nctu.edu.tw/ppisearch/	 Chen	et	al.	NAR	2009	



Rpb4-Rpb7	complex	crystallized	in	both	H.	sapiens	(pdb	code:2c35)		
and	S.	cerevisiae	(pdb	code:1y14).	

Faure	et	al.	Nucleic	Acids	Res.	2012	


